Unifi USG setup VLANS voor IPTV

Beste,
Ik ben sinds kort klant bij Tweak en ben bezig om mijn unifi setup draaide te krijgen.
Ik heb het volgende aangesloten:
ZTE ZXHN f3100 aangesloten op de WAN1 van mn USG
USG lan1 aangsloten op mn unifi switch
Unifi cloudkey gen2 (voor management)

Ik heb mijn tv voorzien van een Vlan 4 only profiel samen met native LAN
rest draait gewoon in Native lan

Ik heb de volgende Json gebruikt:

config.gateway.json

{
“firewall”: {
“source-validation”: “disable”
},
“interfaces”: {
“ethernet”: {
“eth0”: {
“description”: “WAN”,
“duplex”: “auto”,
“speed”: “auto”,
“vif”: {
“4”: {
“address”: [
“dhcp”
],
“description”: “eth0.4 - IPTV”,
“dhcp-options”: {
“client-option”: [
“send vendor-class-identifier “IPTV_RG”;”,
“request subnet-mask, routers, rfc3442-classless-static-routes;”
],
“default-route”: “no-update”,
“default-route-distance”: “210”
}
},
“34”: {
“description”: “eth0.34 - Internet”,
“address”: [
“dhcp”
],
“dhcp-options”: {
“default-route-distance”: “1”,
“default-route”: “update”,
“name-server”: “update”
},
“firewall”: {
“in”: {
“name”: “WAN_IN”
},
“local”: {
“name”: “WAN_LOCAL”
},
“out”: {
“name”: “WAN_OUT”
}
}
}
}
}
}
},
“protocols”: {
“igmp-proxy”: {
“interface”: {
“eth1”: {
“role”: “downstream”,
“threshold”: “1”,
“whitelist”: [
“239.0.0.0/16”,
“225.0.71.0/24”,
“224.0.0.0/16”
]
},
“eth0”: {
“role”: “disabled”,
“threshold”: “1”
},
“eth0.4”: {
“alt-subnet”: [
“0.0.0.0/0”
],
“role”: “upstream”,
“threshold”: “1”
},
“eth0.34”: {
“role”: “disabled”,
“threshold”: “1”
},
“eth2”: {
“role”: “disabled”,
“threshold”: “1”
}
}
},
“static”: {
“route”: {
“185.24.175.0/24”: {
“next-hop”: {
“10.10.32.1”: “’’”
}
}
}
}

},
“service”: {
“nat”: {
“rule”: {
“2”: {
“description”: “ipv-srtp-abox1”,
“inbound-interface”: “eth0.4”,
“inside-address”: {
“address”: “192.168.1.30”,
“port”: “555-65000”
},
“log”: “disable”,
“protocol”: “udp”,
“source”: {
“address”: “185.24.175.0/24”
},
“type”: “destination”
},
“5000”: {
“description”: “MASQ corporate_network to IPTV network”,
“log”: “disable”,
“outbound-interface”: “eth0.4”,
“protocol”: “all”,
“type”: “masquerade”
},
“5001”: {
“description”: “MASQ corporate_network to WAN”,
“log”: “disable”,
“outbound-interface”: “eth0.34”,
“protocol”: “all”,
“type”: “masquerade”
}
}
}
}
}

Nu werkt uitzending gemist wel gewoon en kijk vanaf het begin.
Maar Live TV nog niet.
Ik heb het Gateway IP gegokt op basis van het destination IP wat ik krijg op eth0.4 van mijn USG (netstat -rn) Echter staat die er niet zelf als gateway ip alleen mijn port forwards
Weet iemand waar ik iets over het hoofd zie?

alvast bedankt.

Update:
Het werkt nu nadat ik de USG aan en uit heb gezet.