Unifi USG IPTV loopt vast

Ik heb geprobeerd om de modem van Tweak te vervangen door mijn Ubiquiti Unifi USG. Ik heb de instellingen aangepast zoals beschreven op de website van Tweak.
Alles werkt, dus ook met VLANs naar de WAN kant toe; Begin Gemist, gids, opnemen, uitgesteld kijken en live TV. Het enige wat niet werkt is dat als ik een programma kijk via Begin Gemist en dit op pauze zet, daarna het programma niet meer hervat wordt en het beeld bevriest.

Ik heb RTSP aangezet op mijn USG en de configuratie is als volgt:

USG -> Unifi Switch 8 -> IPTV. Ik heb een apart VLAN aangemaakt op eth1 met IGMP Snooping aan in de Controller interface. Aan de poort op de Switch waaraan de IPTV ontvanger hangt heb ik expliciet het VLAN (in mijn geval 661) aan die poort gekoppeld en de andere poorten aan het LAN profiel.

Daarnaast de config.gateway.json geplaatst en op Provision geklikt in de interface. Mist is nog iets wat betreft UDP poorten die open moeten staan of iets dergelijks?

{
  "interfaces": {
    "ethernet": {
      "eth0": {
        "dhcp-options": {
          "default-route": "no-update",
          "default-route-distance": "1",
          "name-server": "no-update"
        },
        "vif": {
          "4": {
            "address": [
              "dhcp"
            ],
            "description": "WAN",
            "dhcp-options": {
              "client-option": [
                "send vendor-class-identifier "IPTV_RG";",
                "request subnet-mask, routers, rfc3442-classless-static-routes;"
              ],
              "default-route": "no-update",
              "default-route-distance": "210",
              "name-server": "no-update"
            },
            "ip": {
              "source-validation": "loose"
            }
          },
          "34": {
            "address": [
              "dhcp"
            ],
            "description": "WAN",
            "firewall": {
              "in": {
                "ipv6-name": "WANv6_IN",
                "name": "WAN_IN"
              },
              "local": {
                "ipv6-name": "WANv6_LOCAL",
                "name": "WAN_LOCAL"
              },
              "out": {
                "ipv6-name": "WANv6_OUT",
                "name": "WAN_OUT"
              }
            }
          }
        }
      }
    }
  },
  "protocols": {
    "igmp-proxy": {
      "interface": {
        "eth0": {
          "role": "disabled",
          "threshold": "1"
        },
        "eth0.4": {
          "alt-subnet": [
            "0.0.0.0/0"
          ],
          "role": "upstream",
          "threshold": "1"
        },
        "eth0.34": {
          "role": "disabled",
          "threshold": "1"
        },
        "eth1": {
          "role": "disabled",
          "threshold": "1"
        },
        "eth1.661": {
          "alt-subnet": [
            "0.0.0.0/0"
          ],
          "role": "downstream",
          "threshold": "1",
          "whitelist": [
            "239.0.3.0/16",
            "225.0.71.0/24",
            "224.0.0.0/16"
          ]
        }
      }
    },
    "static": {
      "route": {
        "185.24.175.0/24": {
          "next-hop": {
            "10.x.x.x": "''"
          }
        },
        "185.41.48.0/24": {
          "next-hop": {
            "10.x.x.x": "''"
          }
        }
      }
    }
  },
  "port-forward": {
    "wan-interface": "eth0.34"
  },
  "service": {
    "dns": {
      "forwarding": {
        "except-interface": [
          "eth0.34"
        ]
      }
    },
    "nat": {
      "rule": {
        "5000": {
          "description": "MASQ corporate_network to IPTV network",
          "destination": {
            "address": "185.24.175.0/24"
          },
          "log": "disable",
          "outbound-interface": "eth0.4",
          "protocol": "all",
          "type": "masquerade"
        },
        "5001": {
          "description": "MASQ corporate_network to IPTV network",
          "destination": {
            "address": "185.41.48.0/24"
          },
          "log": "disable",
          "outbound-interface": "eth0.4",
          "protocol": "all",
          "type": "masquerade"
        },
        "6001": {
          "outbound-interface": "eth0.34"
        },
        "6002": {
          "outbound-interface": "eth0.34"
        },
        "6003": {
          "outbound-interface": "eth0.34"
        }
      }
    }
  },
  "system": {
    "task-scheduler": {
      "task": {
        "iptv": {
          "executable": {
            "path": "/config/scripts/post-config.d/update_iptv_route.sh"
          },
          "interval": "15m"
        }
      }
    }
  }
}

Bij Tweak is het niet nodig om het update route script te draaien. deze wijzigd niet. (tenminste de afgelopen 2 jaar bij mij niet)
Verder zou je bij de MASQ regels gewoon de interface moeten opgeven ipv de iprange dan heb je ook maar 1 regel nodig en niet 2 (5000 en 5001)
Op dit forum staat trouwens een stukje over rtsp (Gebruik Unifi USG) Dat heeft voor mij de laatste issues met terugkijken etc opgelost.

Thanks, ik heb dat nu aangepast; daarnaast zag ik in een ander topic nog de volgende firewall rules:

{
"2": {
          "description": "ipv-srtp-abox",
          "inbound-interface": "eth0.4",
          "inside-address": {
            "address": "192.168.2.1",
            "port": "555-65000"
          },
          "log": "disable",
          "protocol": "udp",
          "source": {
            "address": "185.24.175.0/24"
          },
          "type": "destination"
        },
        "3": {
          "description": "ipv-srtp-abox",
          "inbound-interface": "eth0.4",
          "inside-address": {
            "address": "192.168.2.1",
            "port": "555-65000"
          },
          "log": "disable",
          "protocol": "udp",
          "source": {
            "address": "185.41.48.0/24"
          },
          "type": "destination"
        }
}

Zijn deze nodig en zo ja, wat doen ze?

Die firewall rules gebruikt niemand in NL volgens mij.
Ik heb net even het journaal van gisteren gestart. gepauzeerd. en na 5 minuten weer geresumed, en zie geen problemen. Wat wel opvalt is dat jij geen aparte macadressen gebruikt voor je wan interface. Ik moest daar toen (lang lang geleden) aparte mac adressen specificeren voor vlan4 en 34. Maar dan zou je ook meer problemen moeten hebben.

@reinierh ik heb dit allemaal ingesteld (ik heb de config zoals jij die ooit hebt geplaatst gebruikt), maar pauze loopt nog steeds vast. As we speak met Tweak aan de lijn…

Heb je al meer geluk gehad?

Anders zou je eventueel een capture kunnen maken van het verkeer in je TV VLAN, en daarin kijken of er rare dingen gebeuren met het verkeer.

Bevroren beeld klinkt alsof de switchport geen deel meer is van de multicast group en de box de laatst ontvangen data blijft weergeven.

Anderzijds kun je wat commando’s opzoeken voor je switch, om daarmee de status van de multicast group te controleren.

Het is ondertussen gelukt. De config die ik gebruik is de volgende:

{
  "interfaces": {
    "ethernet": {
      "eth0": {
        "vif": {
          "4": {
            "address": [
              "dhcp"
            ],
            "description": "WAN - IPTV",
            "mac": "xxxxxxx",
            "dhcp-options": {
              "client-option": [
                "send vendor-class-identifier "IPTV_RG";",
                "request subnet-mask, routers, rfc3442-classless-static-routes;"
              ],
              "default-route": "no-update",
              "default-route-distance": "220",
              "name-server": "update"
            },
            "egress-qos": "0:5",
            "ip": {
              "source-validation": "loose"
            }
          },
          "34": {
            "description": "WAN - Internet",
            "mac": "xxxxxxx",
            "address": [
              "dhcp"
            ],
            "egress-qos": "0:2",
            "dhcp-options": {
              "default-route": "update",
              "default-route-distance": "1",
              "name-server": "no-update"
            },
            "firewall": {
              "in": {
                "ipv6-name": "WANv6_IN",
                "name": "WAN_IN"
              },
              "local": {
                "ipv6-name": "WANv6_LOCAL",
                "name": "WAN_LOCAL"
              },
              "out": {
                "ipv6-name": "WANv6_OUT",
                "name": "WAN_OUT"
              }
            }
          }
        }
      }
    }
  },
  "port-forward": {
    "auto-firewall": "enable",
    "wan-interface": "eth0.34"
  },
  "protocols": {
    "static": {
      "interface-route": {
        "0.0.0.0/0": {
          "next-hop-interface": {
            "eth0.34": "''"
          }
        }
      },
      "route": {
        "185.24.175.0/24": {
          "next-hop": {
            "10.x.x.x": "''"
          }
        },
        "185.41.48.0/24": {
          "next-hop": {
            "10.x.x.x": "''"
          }
        }
      }
    },
    "igmp-proxy": {
      "interface": {
        "eth0.4": {
          "alt-subnet": [
            "0.0.0.0/0"
          ],
          "role": "upstream",
          "threshold": "1"
        },
        "eth1.661": {
          "role": "downstream",
          "threshold": "1",
          "whitelist": [
            "239.0.3.0/16",
            "225.0.71.0/24",
            "224.0.0.0/16"
          ]
        },
        "eth0.34": {
          "role": "disabled",
          "threshold": "1"
        },
        "eth1": {
          "role": "disabled",
          "threshold": "1"
        }
      }
    }
  },
  "service": {
    "dns": {
      "forwarding": {
        "except-interface": [
          "eth0",
          "eth0.34",
          "eth0.4"
        ]
      }
    },
    "nat": {
      "rule": {
        "2": {
          "description": "ipv-srtp-abox",
          "inbound-interface": "eth0.4",
          "inside-address": {
            "address": "192.168.2.2",
            "port": "555-65000"
          },
          "log": "disable",
          "protocol": "udp",
          "source": {
            "address": "185.24.175.0/24"
          },
          "type": "destination"
        },
        "3": {
          "description": "ipv-srtp-abox",
          "inbound-interface": "eth0.4",
          "inside-address": {
            "address": "192.168.2.2",
            "port": "555-65000"
          },
          "log": "disable",
          "protocol": "udp",
          "source": {
            "address": "185.41.48.0/24"
          },
          "type": "destination"
        },
        "5001": {
          "description": "MASQ corporate_network to IPTV network",
          "log": "disable",
          "outbound-interface": "eth0.4",
          "protocol": "all",
          "type": "masquerade"
        },
        "6001": {
          "description": "MASQ corporate_network to WAN",
          "log": "disable",
          "outbound-interface": "eth0.34",
          "protocol": "all",
          "source": {
            "group": {
              "network-group": "corporate_network"
            }
          },
          "type": "masquerade"
        },
        "6002": {
          "description": "MASQ guest_network to WAN",
          "log": "disable",
          "outbound-interface": "eth0.34",
          "protocol": "all",
          "source": {
            "group": {
              "network-group": "guest_network"
            }
          },
          "type": "masquerade"
        }
      }
    }
  },
  "system": {
    "conntrack": {
      "modules": {
        "sip": "disable"
      },
      "expect-table-size": "2048",
      "hash-size": "32768",
      "table-size": "262144"
    }
  }
}

Na het toevoegen van de firewall rules 2 en 3 werkte het ineens wel. Ook nog een keer de USG opnieuw gestart dus weet nou niet zeker of het daaraan ligt of aan de firewall rules. Maar ik durf die rules nu ook niet meer weg te halen :sweat_smile:

2 likes

@mmjmanders Bedankt voor het uitzoeken en het posten van de configuratie.
Is het mogelijk dat ik deze configuratie overneem, mijn eigen MAC adressen er inzet en dan gewoon direct gebruik in de Unifi USG? Ik ben niet blij met de stabiliteit van de Zyxel router wil graag overstappen in het Ubiquitti ecosysteem maar ik kijk erg op tegen het van de grond af aan opbouwen van deze configuratie.

@meije702 Wat ik heb gedaan is het MAC adres van de door Tweak geleverde modem/router overnemen als MAC adres voor de interface met VLAN34 en het MAC adres van VLAN4 is bij het laatste cijfer eentje opgeteld. Ik heb eens gelezen dat dat in het verleden nodig zou zijn maar nu niet meer; ik heb het voor de zekerheid maar gedaan

1 like

Dat is nog steeds nodig.

1 like