Standaard DNS setting in Fritz router via DHCP werkt niet

De computers/telefoons die connecten met de Fritz router krijgen het 192.x.x.x DNS ip-adres echter geldt dat name resolving dan helemaal niet werkt. Ik moet dus zelf op die machines 8.8.8.8 van Google en 1.1.1.1 als voorbeeld instellen en dan kan ik wel internetten.

Echter door Corona werken we nu ook thuis met een laptop van het werk waarbij je zelf NIET de DNS mag aanpassen (domein administrator wachtwoord nodig) en kom ik dus door die DNS die de Fritz router via DHCP uitgeeft niet op internet (alleen via ip-adressen wat natuurlijk niet werkt).

Hoe krijg ik in de Fritz router de DNS zo ingesteld dat ik kan internetten? En als het niet anders is hoe stel ik 8.8.8.8 en 1.1.1.1 in als de DNS die de DHCP server in de Fritz box moet uitdelen?

heel simpel log in
klik op internet, toegangsgegevens, DNS-server.

mocht je dit niet zien staan?
klik rechtsboven aan op de 3 puntjes en zet daar geavanceerde opties aan.

succes

Dat dacht ik dus ook. Ik heb die setting doorgevoerd:

Dan opmerking dat je met een telefoonnummer moet doorvoeren maar dat is gelukt met ook een button drukken. Als ik uitlog, inlog dan staat die setting er nu gewoon en standaard.

Nu opnieuw verbinding gemaakt en nog steeds:

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : fritz.box
Description . . . . . . . . . . . : Intel® Wireless-AC 9560 160MHz
Physical Address. . . . . . . . . : 38-00-25-79-22-73
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::d00f:59d0:6852:22e2%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.178.34(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Monday, 6 April 2020 10:42:38
Lease Expires . . . . . . . . . . : Thursday, 16 April 2020 10:42:38
Default Gateway . . . . . . . . . : 192.168.178.1
DHCP Server . . . . . . . . . . . : 192.168.178.1
DHCPv6 IAID . . . . . . . . . . . : 87556133
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-24-62-E5-21-00-D8-61-09-6F-A8
DNS Servers . . . . . . . . . . . : 192.168.178.8
NetBIOS over Tcpip. . . . . . . . : Enabled

Je ziet dus DNS server: 192.168.178.8 staan en dus weer geen internet. (mag maar 1 image plaatsen als nieuwe gebruiker dus die komt wel in een ander antwoord)

Pas ik in netwerk settings van het apparaat het zelf naar 8.8.8.8 en 1.1.1.1 aan dan werkt internet wel.

Dus antwoord wat je geeft had ik zelf ook verwacht als oplossing maar doet het dus niet helaasa.

dns-fritz2

Dus met DNS Servers . . . . . . . . . . . : 192.168.178.8 die de fritz box doorgeeft geen internet. Ik wil dat de fritz box 8.8.8.8 en 1.1.1.1 doorgeeft. Dan werkt het tenminste standaard en hoef ik dit niet handmatig aan te passen.

Mijn vrouw kan nu niet thuiswerken doordat die DNS setting niet goed binnenkomt. Ik heb een alternatieve internet verbinding voor haar geregeld maar ik kan niet verkroppen dat zoiets simpels als die DNS setting niet doorkomt bij de apparaten die met de Fritz box connecten.

je hebt dus zelf een interne DNS op gezet
dat is heel wat anders
ga naar
thuisnetwerk/netwerk/netwerkinstellingen/ klik onderin op IPv4 adressen
en vul dan bij lokale DNS server je IP van je router in dat is dan in jouw geval 192.168.178.1
en het zelfde geld voor je IPv6 config verwijzen naar je router.
dan werkt het wel

ik kan mij nl niet voorstellen dat Tweak dit in zijn config heeft staan dus ben ban dat je zelf hier een foutje hebt gemaakt

en dan kan je in mijn vorige bericht alles weer op standaard zetten

Nee ik heb geen interne DNS opgezet.
Ik heb de DNS van Google nodig: https://www.security.nl/posting/573218/Google%3A+tien+procent+internetters+gebruikt+Google-dns+8_8_8_8

En deze: https://1.1.1.1/dns/

Als voorbeeld nodig om uberhaupt te kunnen internetten.
Als ik de DNS gebruik die de Fritz router uitdeelt en dus zo’n 192.x.x.x. DNS van Fritz router zelf is dan werkt de name resolving NIET en kan ik dus niet internetten.

Dus nee, ik heb niet zelf een DNS service opgezet. Ik moet gebruik maken van externe DNS’en om het uberhaupt op een apparaat te laten werken.

Ik zal je antwoord nog eens doornemen en kijken of het dan wel goed komt en laat ik nog weten maar mijn simpele opmerking is dus dat de DNS die de fritz router standaard doorgeeft geen werkende name resolving heeft

dat komt omdat je verwijst naar 192.168.178.8 en dat is waarschijnlijk geen DNS server maar iets anders of misschien helemaal niets
dus verwijs hem daar naar 192.168.178.1 en dan komt het helemaal goed

ik gebruik zelf geen google DNS die gaat via een static route gewoon naar mijn pi-hole
google weet al genoeg van mij.

Aha… omdat je verwijst naar 192.168.178.8 … Ik verwijs niets, ik krijg die .8 op het einde van de Fritz router door maar ik zal dat eens naar .1 zetten en kijken of het dan goed komt. En daarna uitzoeken waar die 192.168.178.8 vandaan komt. In ieder geval niet iets wat ik doe en echt door de Fritz router zelf uitgedeeld wordt.

Als ik het zelf handmatig op een apparaat instel:

DNS Servers . . . . . . . . . . . : 8.8.8.8
1.1.1.1

Dan werkt het. Laat ik het door de Fritz router geautomatiseerd uitdelen dan krijg ik:

DNS Servers . . . . . . . . . . . : 192.168.178.8

Dus niet iets wat ik zelf inregel.

En dat wat je aangaf

ga naar
thuisnetwerk/netwerk/netwerkinstellingen/ klik onderin op IPv4 adressen
en vul dan bij lokale DNS server je IP van je router in dat is dan in jouw geval 192.168.178.1

Dat kan dus niet op die machine van mijn vrouw van haar werk omdat je daar de netwerkinstellingen niet op mag wijzigen omdat dit alleen door de beheerder van het werk gedaan kan worden met domein wachtwoord.

Dus nog steeds geldt dat die Fritz router 192.168.178.8 uitdeelt waarmee het NIET werkt.

Iemand een idee waarom 192.168.178.8 uitgedeeld wordt en niet 192.168.178.1 ?

lees even terug je moet dat in de fritz instellen

thuisnetwerk/netwerk/netwerkinstellingen/ klik onderin op IPv4 adressen
en vul dan bij lokale DNS server je IP van je router in dat is dan in jouw geval 192.168.178.1
en het zelfde geld voor je IPv6 config verwijzen naar je router.
dan werkt het wel

Super bedankt ! Het is gelukt:

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : fritz.box
Description . . . . . . . . . . . : Intel® Wireless-AC 9560 160MHz
Physical Address. . . . . . . . . : 38-00-25-79-22-73
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::d00f:59d0:6852:22e2%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.178.34(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Monday, 6 April 2020 13:28:59
Lease Expires . . . . . . . . . . : Thursday, 16 April 2020 13:54:35
Default Gateway . . . . . . . . . : 192.168.178.1
DHCP Server . . . . . . . . . . . : 192.168.178.1
DHCPv6 IAID . . . . . . . . . . . : 87556133
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-24-62-E5-21-00-D8-61-09-6F-A8
DNS Servers . . . . . . . . . . . : 192.168.178.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Geen idee hoe daar dan ooit die .8 gekomen is. Kan me niet voorstellen dat ik die ingegeven heb maar je weet nooit.

Nu wordt netjes DNS Servers . . . . . . . . . . . : 192.168.178.1
uitgedeeld en werkt het direct.

SUPER BEDANKT!

natuurlijk werkt dat :slight_smile:

maar dat kan naar mijn idee alleen door een handmatige actie gekomen zijn
maar blij dat je weer kan internetten .
persoonlijk zou ik de google servers weer uitzetten.
en als je de tweak DNS wilt testen tegen over die van Google kan je dit progje gebruiken
interessant tooltje