Microtik & SIP (opgelost)

Voor iedereen die ook aan 't spelen is met mikrotik (RB2011UiAS), en probeert SIP aan de gang te krijgen, ik ben lang aan 't vechten geweest, waarbij ik op 't verkeerde been ben gezet door verschillende voorbeeld configuraties en adviezen op fora.

  • Zorg dat je op de laatste firmware zit (6.47.7), oudere versies lijken problem te geven.
  • Firewall -> Service Ports -> sip: aanzetten port 5060 en 5061 en activeer media direct
  • Firewall -> Connections -> Tracking -> Enabled: yes + Loose TCP tracking, waarden default laten. Let op: op enabled: auto zorgt ervoor dat je inkomend geen geluid hebt!
  • Geen port-forwarding instellen!

Ik gebruik een simpele Yealink W52P telefoon, instellingen:

  • Outbound Proxy server: sip.tweakphone.nl, port 5060
  • STUN server: stun.l.google.com, port 19302
  • Local SIP port: 5060
  • Min RTP Port: 9000
  • Max RTP Port: 10999

Hopelijk kan ik hier iemand een plezier mee doen

1 like

En hiermee zet je ook anderen weer op het verkeerde been :slight_smile:

De SIP-helper zorgt in het algemeen voor minder transparantie en daardoor meer problemen. Oudere versies hebben naar mijn weten geen problemen gegeven. Althans vanaf versie 6.37.1 geen issues gehad.

  • SIP helper uit
  • Connection tracking op auto (is toch ingeschakeld bij NAT)
  • Inderdaad geen port forwarding
  • Geen STUN-server
  • Geen min/max RTP-poorten
  • Local SIP-port is n.v.t.

Ik vermoed dat je een issue hebt met established,related connections; met een default config (factory default) zou SIP probleemloos moeten werken (signalling + audio) met als enige aanpassing:

/ip firewall service-port
set sip disabled=true

Een bijkomend nadeel van de SIP-helper is dat deze niet meer bruikbaar is als je SIP over TLS gebruikt.

Zodra ik sip helper uitzet, is het bij mij gedaan met de connectie, zonder stun trouwens ook., idem voor connection tracking op auto…

Gisteren nog eens config gehaald, je suggesties nogmaals geprobeerd… maar bij mij wil dat niet. Ook nog even geprobeerd met firewall rules uit, maar dat maakt geen verschil. Overigens zit voice bij mij in een apart vlan, dat zou evt nog uit kunnen maken.