Internet en Bellen icm OpenWRT Xiaomi R3P

Hopelijk kunnen jullie mij ook helpen.
Modem: Xiaomi R3P. De firmware is vervangen door openwrt wat dus een universele configuratiebestand ondersteund. Dit ziet er momenteel als volgt uit (maar werkt niet). Mijn abonnement is 1gb glasvezel Internet + bellen

LAN interface (fysieke switch poorten)

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option ip6assign ‘60’

[0] Pas hieronder aan of laat staan: IP-adres van router

option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’

[1] IGMP snooping of proxying moet worden toegepast op VLAN 4

option igmp_snooping ‘1’
option defaultroute ‘0’
option peerdns ‘0’

WAN interface (fysieke WAN poort)

config interface ‘wan’

[1] Bij alle nieuwe verbindigen wordt er gebruik gemaakt van DHCP

option proto ‘dhcp’

[1] Voor al het ‘gewone’ internet-verkeer wordt VLAN 34 gebruikt

option ifname ‘eth1.34’

[2] Pas hieronder aan: MAC-adres die achterop de officiele Tweak router staat

option macaddr ‘xx.xx’
option defaultroute ‘1’
option peerdns ‘1’

[1] Default route over VLAN 4

option defaultroute ‘34’
option peerdns ‘0’

Interne switch (WNDR3700)

config switch
option name ‘rtl8366s’
option reset ‘1’
option blinkrate ‘2’
option enable_vlan ‘1’
option enable_vlan4k ‘1’

Untag VLAN 1 op alle LAN poorten (WNDR3700)

config switch_vlan
option vlan ‘1’
option device ‘rtl8366s’
option ports ‘0 1 2 3 5t’

Stel VLAN 34 voor WAN in op CPU poort (WNDR3700)

config switch_vlan
option vlan ‘34’
option device ‘rtl8366s’
option ports ‘5t’

[3] Poort 4 op switch met VLAN 1 als default (WNDR3700)

config switch_port
option led ‘6’
option port ‘0’
option pvid ‘1’
option device ‘rtl8366s’

[3] Poort 3 op switch met VLAN 1 als default (WNDR3700)

config switch_port
option led ‘6’
option port ‘1’
option pvid ‘1’
option device ‘rtl8366s’

[3] Poort 2 op switch met VLAN 1 als default (WNDR3700)

config switch_port
option led ‘6’
option port ‘2’
option pvid ‘1’
option device ‘rtl8366s’

[3] Poort 1 op switch met VLAN 1 als default (WNDR3700)

config switch_port
option led ‘6’
option port ‘3’
option pvid ‘1’
option device ‘rtl8366s’

[3] Ongebruikte poort op switch (WNDR3700)

config switch_port
option port ‘4’
option device ‘rtl8366s’

[3] Poort op switch die verbind met CPU (WNDR3700)

config switch_port
option led ‘6’
option port ‘5’
option device ‘rtl8366s’

DANK!

Ik heb je bericht even afgesplitst in een nieuw topic, omdat dit toch specifiek over OpenWRT gaat. Zelf heb ik vrij weinig ervaring met OpenWRT, maar kun je aangeven wat er specifiek niet werkt?

Mark, dank je wel. Eigenlijk alles: Ik heb helemaal geen internet uit de modem

Heb zelf 1 keer als test OpenWRT op Tweak gehad, maar verder niet in de configuratiebestanden gedoken. Nadat ik de WAN interface had ingesteld op VLAN34 via de webinterface van OpenWRT 'werkte het gewoon". Zelfde abonnement.

Heb je misschien ook logs? Wellicht kunnen we daar uithalen wat er aan de hand is.

Ik zal kijken of ik de logs kan zien. BvD.

Weet je nog wat je hier had ingesteld? bv alle LAN tagged / untagged / off etc?
Ik ga zo een laptop met een ethernet poort regelen om met de modem verbinding te maken

Ik had geen speciale configuratie op mijn LAN.

Het is voldoende om enkel de WAN poort te configureren op VLAN34. Zodra je router die poort gebruikt om DHCP requests te doen krijg je een IP adres en kan je het internet op.

Tekstbestanden zijn blijkbaar niet toegestaan als bijlage…text is lang. Ideen?
Ik zal de configuratie nog een keer handmatig doorlopen.
Ethernet verder gewoon op WAN poort?

Probeer https://p.6core.net of https://paste.0x5e.eu :slight_smile:

Heeft heel veel tijd en moeite gekost maar uiteindelijk aan de praat gekregen. Internet werkt, moet de LAN settings nog even onderzoeken. Ik zal daarna de configuratie bestand delen zodat hopelijk anderen er ook baat bij kunnen hebben.

Werkende ‘network’ configuratiebestand voor modems met OPENWRT

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘xxxjouwmacadressxxx’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’

config device ‘lan_dev’
option name ‘eth0.1’
option macaddr ‘xxx:jouwmacadress:xxx’

config interface ‘wan’
option proto ‘dhcp’
option ifname ‘eth0.34’

config interface ‘wan6’
option proto ‘dhcpv6’
option ifname ‘eth0.34’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘6t 3 2 1’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option vid ‘34’
option ports ‘6t 3t 2t 1t 4t’

Veel success

2 likes