Gebruik Unifi USG

Volgens mij wordt de FS-converter geleverd met SFP-module. Maar het kan zijn dat dit speciaal voor Tweak + Glasvezel De Wolden is gedaan.

In mijn doos zit de
Solid-Optics.com GLC-BX-U20-SO
Speed: 1,25G
TX freq: 1310 nm
RX freq: 1490 nm
Afstand: 20km

Ik heb ook de media fs converter ontvangen inclusief sfp module, maar dan in de regio Montfoort

Volgens mij is dat standaard. Ik heb de media converter ook nog liggen, maar de SFP heeft de monteur weer meegenomen. Ik had zelf al een werkende SFP in m’n router zitten (een TP-Link TL-SM321B)

@Mbovenka, ondertussen kunnen we jouw SFP dromen. Jij noemt die in bijna iedere post. Toch toevallig geen werknemer van TP-Link? :crazy_face:

Blijft vreemd dat de monteur de SFP heeft meegenomen. Jij hebt daar borg voor betaald. Ik hoop voor jou dat het goed geregistreerd staat, anders blijft de borg bij Tweak … :wink:

Grijns. Nee. Maar om de een of andere reden wordt deze vraag regelmatig gesteld, en als ik hem zie geef ik er antwoord op. En de TP-Link a) werkt (want ik gebruik hem) en b) is heel redelijk geprijsd.

Je betaalt voor de mediaconverter & SFP overigens geen borg; je betaalt alleen €25 administratiekosten.

Na wat inlezen en 2 configuraties van @ TK18088809 en @ reinierh te combineren heb ik ook de laatste stap durven zetten. De USG (niet de pro) die tot op heden achter de FritzBox zat is nu ook de router.

Mijn huis heeft een FTU (grondplaat) met daarop 1 NTU (die was passief en achtergelaten door de vorige bewoner) en 1 module die niet echt actief te noemen was maar gewoon de glasvezelkabel doorverbind via een SC connector naar de FritzBox. Nu liep ik initieel te tobben hoe ik van SC naar UTP (ik heb niet de USG Pro) moest en keek dus naar een media convertor. Tot me duidelijk werd dat de Packetfront MC901 een vroeger door KPN gebruikte media convertor is. Ik had het ding nooit goed bekeken en zag ineens de ethernet aansluiting. Packetfront is kennelijk weer overgenomen later door Genexis, en de cirkel is rond.

Daarna heb ik dus als eerste:

  • Een 12v/0.5 ampere voeding op de kop getikt om de Packetfront werkend te krijgen
  • De “passieve” NTU SPF SC module eraf gehaald en de Packetfront NTU op dit slot geplaatst
  • met root@ip-cloudkey ingelogd op mijn unifi cloud key
  • vi /usr/lib/unifi/data/sites/default/config.gateway.json (content zie attachment)
  • chown unifi:unifi /usr/lib/unifi/data/sites/default/config.gateway.json
  • en vervolgens via Unifi Network een force provision gedaan op mijn USG

Wonderbaarlijk, in 1x werkte het. Al duurde de provision +/- 1-2 minuten en daarna ook nog even voor mijn internet verbinding echt online kwam.

Dit is mijn config:

config.gateway.json
{  
    "interfaces":{  
        "ethernet":{  
            "eth0":{
                "description": "WAN",
                "duplex": "auto",
                "speed": "auto",
                "vif":{  
                    "4": {
                        "address": [
                            "dhcp"
                        ],
                        "description": "eth0.4 - IPTV",
                        "dhcp-options": {
                            "client-option": [
                                "request subnet-mask, routers, rfc3442-classless-static-routes;"
                            ],
                            "default-route": "no-update",
                            "default-route-distance": "210"
                        }
                    },
                    "34":{  
                        "description": "eth0.34 - Internet",
                        "mac":"7c:00:00:00:00:f1",
                        "address":[  
                            "dhcp"
                        ],
                        "egress-qos":"0:2",
                        "dhcp-options":{  
                             "default-route":"update",
                             "default-route-distance":"1",
                             "name-server":"no-update"
                        },
                        "firewall":{  
                            "in":{  
                                "ipv6-name":"WANv6_IN",
                                "name":"WAN_IN"
                            },
                            "local":{  
                                "ipv6-name":"WANv6_LOCAL",
                                "name":"WAN_LOCAL"
                            },
                            "out":{  
                                "ipv6-name":"WANv6_OUT",
                                "name":"WAN_OUT"
                            }
                        }
                    }
                }
            }
        }
    },
    "protocols": {
        "igmp-proxy": {
            "interface": {
                "eth1": {
                    "role": "downstream",
                    "threshold": "1",
                    "whitelist": [
                        "239.0.0.0/16",
                        "225.0.71.0/24",
                        "224.0.0.0/16"
                    ]
                },
                "eth0": {
                    "role": "disabled",
                    "threshold": "1"
                },
                "eth0.4": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "upstream",
                    "threshold": "1"
                },
                "eth0.34": {
                    "role": "disabled",
                    "threshold": "1"
                },
                "eth2": {
                    "role": "disabled",
                    "threshold": "1"
                }
            }
        }
    },
    "service": {
        "nat": {
            "rule": {
                "5000": {
                    "description": "MASQ corporate_network to IPTV network",
                    "log": "disable",
                    "outbound-interface": "eth0.4",
                    "protocol": "all",
                    "type": "masquerade"
                },
                "5001": {
                    "description": "MASQ corporate_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "type": "masquerade"
                }
            }
        }
    }
}

Paar opmerkingen:

  • ik heb hem zo simpel mogelijk willen houden
  • ik heb geen TV alleen internet, maar toch vif 4 geconfgureerd (was me niet duidelijk of dat echt nodig was)
  • voor ethernet - eth0 - vif - 34 heb ik mijn MAC adres overgenomen uit de Zyxel in de hoop/verwachting dat ik mijn oude vertrouwde 82.197.Y.Z kon behouden. Maar blijk nu toch een nieuw 217.19.Y.Z te hebben. Wordt morgen weer een paar pull requests inschieten om mijn IP opnieuw te whitelisten voor een paar projecten/klanten. :smiley:
  • Om eerlijk te zijn begrijp ik niet wat de CIDR ranges in protocols -> igmp-proxy -> interface -> eth1 -> whitelist doen. Maar toch maar overgenomen voor de zekerheid.

Hopelijk helpt dit weer anderen en dank voor jullie hulp :slight_smile:

was allemaal niet nodig geweest als je alleen internet met bellen hebt.
dan alleen Vlan34 nodig voor de rest niets.

en je had de Mac van je Fritzbox moeten meenemen want daar had je de 82.197.x.y. IP op
en IP is gekoppeld aan je Mac van uitgaand dat je een vast IP hebt.

Hoi @MrD / Duncan, had al zo’n vermoeden mbt VLAN4 maar was blij dat het werkte initieel. Zal hem eens weghalen.

Wat betreft MAC adres weet ik hoe DHCP werkt. Althans dat denk ik op high level. :-p Vandaar dat ik ook een poging had gedaan dit mee te nemen onder VLAN 34 omdat het terugkwam in de uitleg hierboven. En daarnaast het de enige plek is waar ik een MAC adres kwijt leek te kunnen.

oh dat geloof ik direct ,
ik heb zelf al vanaf het begin een vast IP (wel een keer gwisseld ivm een upgrade vanuit Tweak)

maar elke router die ik getest heb had ik wel steeds mijn '“eigen” IP door de macadress clone

dus als je een vast IP heb moet het werken

Het overnemen van het MAC adres op de USG was noodzakelijk omdat de USG anders opbeide VLAN’s hetzelfde macadres gebruikt. En dan geeft TWEAK maar 1 ip adres (dat ws tenminste in het begin zo.)
Als jij alleen internet hebt, had je dit via de controller heel eenvoudig kunnen configureren.
Alleen voor TV moet je dus dingen regelen…

2 likes

Beste Allen,

Omdat mijn zyxel steeds onstabieler wordt, heb ik nu ook maar de USG geprobeerd.

Wat een verademing! Mijn pingtijden zijn nog nooit zo laag geweest en dat is ook van invloed op de internet-ervaring. Tevens kan ik nu fatsoenlijk iedereen tegelijk op internet laten.

Ik heb grotendeels de config uit de openings-post overgenomen, maar ik heb wel nog 1 ding wat niet werkt. “Begin gemist” op live-tv.

Live-tv doet het
Uitzendingen terugkijken na afloop doet het.
Maar vanaf het begin kijken als een aflevering/film nog bezig is doet het niet :frowning:

Wie weet meer van de techniek en hoe ik dit ook werkend krijg?

Ik heb een edgerouter en ik weet niet of het op een USG hetzelfde werkt, maar probeer dit eens:

set system conntrack modules rtsp enable

Dit werkte iets anders op een USG , maar de oplossing zelf (module aanzetten) was inderdaad de goede. Mijn tv doet het nu volledig, dank je wel!

USG commando: sudo modprobe nf_nat_rtsp

Meer info : https://community.ui.com/questions/Enabling-RTSP-conntrack-module-on-USG/d5347de1-fde0-4b7d-a82c-a8266e00bfa4